Symptoms
-
Going to Domains > example.com > File Manager or trying to open a subdirectory from File Manager, the following error is shown:
PLESK_ERROR: Cannot access document root in Plesk File Manager: Unable to open the directory: Unable to find the directory C:Inetpubvhostsexample.comhttpdocs: Access denied
-
The following error is shown when trying to change the subdirectory permissions from File Manager:
PLESK_ERROR: Server Error
500
PleskUtilException
filemng failed: Unable to get the object (C:Inetpubvhostsexample.comhttpdocssubdirectory) security info: (5) Access is denied. at execute “C:Program Files (x86)Pleskadminbinfilemng” jdoe –permissions –list-common “–file=C:Inetpubvhostsexample.comhttpdocssubdirectory” “–accounts=fsg58C0.tmp”(RunTime::RunAsUser::run line 223) (Error code 1)
Cause
Invalid permissions for the website directory.
Resolution
-
Connect to the server via RDP.
-
Start Command Prompt and fix the website directory permissions using the following command:
C:> plesk repair fs example.com
Note: In case the issue persists, perform further steps.
-
Grant Full control applied to This folder, subfolders and files on
%plesk_vhosts%example.comhttpdocs
folder in Properties > Security > Advanced > Permissions > Edit subscription system user jdoe:Note: The subscription system user can be found going to Subscriptions > example.com > Web Hosting Access