Symptoms
- After updating Plesk to Obsidian 18.0.37 or 18.0.37 Update 1, an email message is sent to email account without mailbox with forwarding to external mailbox:
- That email message is stuck in the queue with the following error in the log file
/var/log/maillog
:dovecot_authdb_plesk[9454]: No such user '[email protected]' in mail authorization database
postfix/pipe[25722]: 85728E4020: to=<[email protected]>, relay=plesk_virtual, delay=0.77, delays=0.3/0/0/0.47, dsn=4.2.1, status=deferred (Message can not be delivered at this time )
Cause
Product issue:
- #PPPM-13129 “Updating to Plesk 18.0.37 and later no longer enables email delivery for mail accounts with disabled mailboxes.”
Fixed in:- Plesk Obsidian 10 August 2021 (Linux)
Resolution
New updates to Plesk Obsidian 18.0.37.X are not affected by the bug.
For servers that were previously updated to Obsidian 18.0.37 or 18.0.37 Update 1:
-
Connect to the server using SSH.
-
Back up Postfix configuration:
# cp -a /etc/postfix{,.back}
-
Repair the mail configuration of all mailboxes:
# plesk repair mail -y
Alternatively, if plesk repair mail utility cannot be used:
# plesk db -Ne “select d.name, m.mail_name from domains d, mail m where d.id=m.dom_id and m.postbox=’false'” | while read DOM NAM; do QMAIL=”/var/qmail/mailnames/$DOM/$NAM/.qmail”; if [[ $(grep “dovecot-lda” $QMAIL | wc -l) -eq 0 ]]; then echo “[i] Mailbox not affected: [email protected]$DOM”; else echo “[!] Fixing mailbox: [email protected]$DOM”; sed -i.bkp ‘/dovecot-lda/d’ $QMAIL; echo -e “[i] File backup location: $QMAIL.bkp”; ls -lha $QMAIL.bkp; fi; done