Symptoms
-
After migration from Plesk 11.0.9 to Plesk Onyx 17.5, Bind DNS service is down on destination server:
# systemctl status named-chroot.service
● named-chroot.service – Berkeley Internet Name Domain (DNS)
Loaded: loaded (/usr/lib/systemd/system/named-chroot.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Wed 2017-11-08 00:19:56 UTC; 8min agoserverhost named-checkconf[18466]: zone example.com/IN: NS ‘ns3.example.com’ has no address records (A or AAAA)
serverhost named-checkconf[18466]: zone example.com/IN: NS ‘ns4.example.com’ has no address records (A or AAAA)
serverhost named-checkconf[18466]: zone example.com/IN: not loaded due to errors. -
On Plesk 11.0.9 there is an NS record ns3.example.com, but ns3.example.com doesn’t have A record (also known as clue record).
Cause
Plesk Migrator bug #PMT-4096 which will be fixed in future product updates.
Resolution
Add ‘A’ record(s) for all corresponding ‘NS’ records reported in the error message on the destination server:
Log in to Plesk and go to Websites & Domains > DNS Settings > Add Record.
For additional information refer Plesk documentation .