Symptoms
-
When creating a backup from a Plesk account (Customer, Reseller or Admin), the backup appears listed on a different Plesk account
-
There are Plesk accounts (customer, reseller or admin) configured with the same GUID in the Plesk database:
# plesk db “SELECT guid, COUNT(guid) FROM clients GROUP BY guid HAVING COUNT(guid) > 1”
+————————————–+————-+
| guid | COUNT(guid) |
+————————————–+————-+
| c609b3d2-5e05-481a-b3c6-ed75734caf0a | 2 |
+————————————–+————-+
Cause
Inconsistency in the Plesk database: Duplicated GUID records in clients table
Resolution
-
Connect to the server via SSH
-
# plesk db dump psa > psa.backup`date +%F-%s`.sql
-
Fix the inconsistency by running the following script:
# plesk db -Ne “SELECT guid, count(guid) FROM clients GROUP BY guid HAVING COUNT(guid) > 1” | while read G C; do echo “> DUPLICATED: $G”; for ((i=0;i<(C-1);i++)); do plesk db -Ne “SELECT id, login FROM clients WHERE guid = ‘$G’ limit 1” | while read I L; do plesk db -Ne “UPDATE clients SET guid = UUID() WHERE id = ‘$I'”; echo “- FIXED: $L”; done; done; done; echo “> COMPLETED”
In case the issue still persists, apply the solution from the following article: