Symptoms
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Unable to register Apache Tomcat:
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Apache Tomcat is installed and is shown as running in Plesk at Tools & Settings > Service Management.
OR
Apache Tomcat is installed but cannot be started at Tools & Settings > Service Management: A floating notification says “Service is not configured” and management buttons are grayed out:
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There is no Java applications menu at Domains > example.com.
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Java applications is shown as Off at Tools & Settings > License Management.
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Unable to register PostgreSQL or Microsoft SQL Server:
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PostgreSQL / MS SQL Server is not available in Plesk at Tools & Settings > Database Servers.
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The PostgreSQL / MS SQL Server function icons are grayed-out at Tools & Settings > Service Management.
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PostgreSQL database server support / Microsoft SQL Server support is shown as Off at Tools & Settings > License Management.
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Cause
The installed Plesk license does not have the Power Pack add-on which includes management modules for Apache Tomcat / PostgreSQL / Microsoft SQL Server.
Note: Support for Apache Tomcat has been dropped in Plesk Onyx 17.8. For more information, visit this KB article.
Resolution
Purchase the Power Pack add-on in Plesk Store. For assistance, contact Plesk Online Sales team.
Note: After purchasing the Power Pack add-on, activate it in Plesk by going to Tools & Settings > License Management and clicking Retrieve Keys.
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