Symptoms
Acronis does not load or loads endlessly on the dashboard after Plesk was upgraded to 18.0.34:
Cause
Acronis bug ID CI-10692
Bug in the Acronis Backup Extension which is already fixed.
Resolution
Update the extension to the latest version.
If an update is not possible, follow these steps:
Workaround
- Connect to the server via SSH with root privileges
- Change to
acronis-backup
directory:# cd /usr/local/psa/admin/htdocs/modules/acronis-backup
- Create backups of 2 files:
# mv /usr/local/psa/admin/htdocs/modules/acronis-backup/dashboard.js{,.backup}
# mv /usr/local/psa/admin/htdocs/modules/acronis-backup/schedule.js{,.backup} - download the archive with patched files and unpack it:
# wget https://plesk.zendesk.com/hc/article_attachments/360024498300/htdocs.zip
# unzip htdocs.zip - Remove the archive:
# rm -f htdocs.zip
- Clear cache of your browser and then open Acronis extension page in Plesk again.