Symptoms
- MailEnable is used as a mail server.
-
A lot of spam messages are sent from non-existent mail addresses without SMTP authentication. The following records can be found in
MailEnableAdmin > Servers > localhost > Services and Connectors > SMTP Logs > Activity
:SMTP-IN E36CEC6EB84241AB821F483914F8F3D9.MAI 1284 203.0.113.2 plesk.example.com ESMTP MailEnable Service, Version: 9.00-- ready at 11/09/17 19:03:42 0 0
SMTP-IN E36CEC6EB84241AB821F483914F8F3D9.MAI 1284 203.0.113.2 EHLO EHLO example.com 250-plesk.example.com [203.0.113.2], this server offers 4 extensions 134 21
SMTP-IN E36CEC6EB84241AB821F483914F8F3D9.MAI 1284 203.0.113.2 MAIL MAIL FROM:<[email protected]> 250 Requested mail action okay, completed 43 36
SMTP-IN E36CEC6EB84241AB821F483914F8F3D9.MAI 1284 203.0.113.2 RCPT RCPT TO:<[email protected]> 250 Requested mail action okay, completed 43 31
SMTP-IN E36CEC6EB84241AB821F483914F8F3D9.MAI 1284 203.0.113.2 DATA DATA 354 Start mail input; end with <CRLF>.<CRLF> 46 6 -
Because of that, the server is blocked on the Microsoft public mail services, like outlook.com and hotmail.com, with the following message:
Recipient: [SMTP:[email protected]]
Reason: 550 5.7.1 Unfortunately, messages from [203.0.113.2] weren't sent. Please contact your Internet service provider since part of their network is on our block list (AS3150). You can also refer your provider to http://mail.live.com/mail/troubleshooting.aspx#errors. [CY1NAM02FT007.eop-nam02.prod.protection.outlook.com] -
Server IP 203.0.113.2 is added to
Tools & Settings > Mail Server Settings > Relay options > Use no relay restrictions for the following networks
.
Cause
The open relay is allowed for the server IP, therefore all messages from it are accepted without any authentication.
Resolution
Delete the record which contains the server IP from
Tools & Settings > Mail Server Settings > Relay options > Use no relay restrictions for the following networks
.